문제
시험 점수를 입력받아 90 ~ 100점은 A, 80 ~ 89점은 B, 70 ~ 79점은 C, 60 ~ 69점은 D, 나머지 점수는 F를 출력하는 프로그램을 작성하시오.
입력
첫째 줄에 시험 점수가 주어진다. 시험 점수는 0보다 크거나 같고, 100보다 작거나 같은 정수이다.
출력
시험 성적을 출력한다.
예제 입력 1 복사
100
예제 출력 1 복사
A
소스코드
const fs = require('fs')
const inputData = fs.readFileSync('/dev/stdin')
const score = inputData
if(100 >= score && score >= 90){
console.log('A')
}
else if(89 >= score && score >= 80){
console.log('B')
}
else if(79 >= score && score >= 70){
console.log('C')
}
else if(69 >= score && score >= 60){
console.log('D')
}
else
console.log('F')
후기
- inputData가 받아 오는 데이터의 타입이 숫자이라는 것을 알게 되었다.
- 파이썬과 다르게 자바스크립트는 비교연산자를 2개를 한번에 쓸 수 없다는 것을 알게 되었고 && and 논리 연산자를 직접 사용해 보았다. (||, !) 연산자도 기억하기!
'Algorithm > - JavaScript' 카테고리의 다른 글
백준 14681번 - 사분면 고르기 [node.js] (0) | 2022.06.05 |
---|---|
백준 2884번 - 알람 시계 [node.js] (0) | 2022.06.04 |
백준 2753번 - 윤년 [node.js] (0) | 2022.06.03 |
백준 1330번 - 두 수 비교하기 [Node.js] (0) | 2022.05.31 |
백준 9498번 - 시험 성적 [Node.js] (0) | 2022.05.31 |
백준 2588번 - 곱셈 [Node.js] (0) | 2022.05.28 |
댓글